WordPress 4.9 incluirá protección de errores al editar archivos PHP de plugins o temas

En Noticias, Webmasters por

La próxima versión de WordPress 4.9, que por el momento permanece en fase beta de desarrollo, incluirá algo muy necesario que los usuarios llevan reclamando desde hace ya varios años. Se trata de un editor de archivos integrado más moderno y más seguro.

Novedades WordPress 4.9

Durante toda la vida de WordPress, los usuarios han sufrido imprevistos bastante molestos al emplear este editor de archivos integrado, sobre todo cuando justo después de guardar los cambios te encuentras con la pantalla blanca de la muerte de WordPress. Este problema es más habitual de lo que parece, ya que al ser WordPress una plataforma accesible tanto para usuarios expertos como noveles, suelen ser estos últimos quienes se encuentren con problemas y errores fatales en la mayoría de las ocasiones.

Mejoras en el editor de archivos en la futura versión de WordPress 4.9.

La primera novedad que veremos para proteger a los usuarios de estos incómodos errores, será un nuevo mensaje de advertencia que se mostrará la primera vez que el usuario acceda al nuevo editor de archivos. Esto sucederá tanto al editar temas como editar plugins.

advertencia wordpress 4.9 editor archivos

Este mensaje no será lo suficientemente disuasorio para los usuarios más inexpertos y valientes, quienes se lanzarán sin pensarlo dos veces a editar archivos PHP sin los conocimientos necesarios. Por este motivo, WordPress ha incluido un segundo mecanismo de protección para evitar sorpresas.

A partir de WordPress 4.9, cuando editemos un archivo PHP y exista algún error, podemos guardar sin temor a equivocarnos, porque se integrará un sistema que evitará que se guarden los cambios en caso de error. Todos sabemos lo fácil que es cometer errores de sintaxis al escribir código PHP, que finalmente desembocan en un error fatal que incluso puede dejar inaccesible el panel de administrador.

Otras novedades relacionadas con el editor de archivos.

Además de todo lo mencionado anteriormente, a partir de esta versión, se integrará el editor de archivos de código abierto CodeMirror en el propio núcleo de WordPress. Este editor está escrito en Javascript y ofrecerá ciertas ventajas como la numeración de líneas, resaltado de sintaxis, autocompletado, etc.

Nuevo editor de archivos de WordPress 4.9

Todo esto nos protegerá de ciertas situaciones incomodas en las que tenemos que lidiar con errores, pero aun así es siempre muy recomendable tener en caso de error acceso al alojamiento vía FTP u otro protocolo similar como sFTP.

Etiquetado con:
Este artículo no tiene comentarios, se el primero en dejar uno.

Deja un comentario: